Das Phantom Drive Supportforum

Antworten:

SCSI Treiber läuft nicht auf 7 Enterprise

7 Ultimate wurde auf 7 EP gesetzt.
Nun obiges Problem.
Mehrfache Neuinstallationen und Deinstallationen.
Lauft Virtual CD ev. nicht auf Enterprise ??
Treiber sind unter Drivers alle vorhanden !

Treiber

Der erste KB-Artikel gibt Hilfestellung bei Problemen mit der Treiberinstallation. Bei einer Neuinstallation beachten Sie bitte die Hinweise im zweiten KB-Artikel, insbesondere das temporäre Ausschalten des Virenscanners könnte hier hilfreich sein.

Installation von Virtual CD v10

Es können keine virtuellen Laufwerke für Virtual CD v10.x angelegt werden - Windows Vista und neuer

Re

Ich habe das Thema durch, auch mit der oem.inf.
Es wird der Treiber gefunden des SCSI Adapters. korrektes Symbol bei direktem Verweis
und dann wieder doch nicht !
Plong, plong in Windows.
PNPDriverImportError in der EAZ und der bleibt !

Informationen

Der Artikel 3230 beinhalt auch Instruktionen im Fall, dass keine Lösung funktioniert: Fügen Sie der Anfrage folgende Informationen hinzu:

  • den genauen Wortlaut der Fehlermeldung(en)
  • den vollständigen Inhalt der Virtual CD-Diagnose mit Installationsprotokoll
    Rechtsklick auf das Schnellstartprogramm im Infobereich der Taskleiste -> Virtual CD Programme -> Diagnose anzeigen -> Optionen -> Installationsprotokoll -> OK -> Aktualisieren
    (Wenn das Setup ein Rollback durchführt, kann die Virtual CD-Diagnose nur mit einem Doppelklick auf die Datei vc10diag.exe gestartet werden, die Sie im Verzeichnis ...\Virtual CD v10\System\ finden. Wurde ein vollständiges Rollback durchgeführt, wurde dabei auch die Datei vc10diag.exe gelöscht und es kann nur eine Virtual CD-Diagnose erstellt werden, solange die Fehlermeldung "Virtual CD Treiber konnte nicht installiert werden. Setup wird beendet!" nichtgeschlossen wird.)
  • den Inhalt der Datei C:\Windows\hhdrvi.log
  • den Inhalt der Datei C:\Windows\inf\setupapi.dev.log
Diese Informationen belassen wir natürlich intern!

Vielen Dank und freundliche Grüße

Re

Vorab: Meldungen der Windows EAZ:

PAE enabled.
(in Reg aber von mir disabled)
Could not set scsi security, Error Code 2.
OpenFileMapping, VCD V10 MemSection Failed 2

Mögliche Ursache: Treiber ist nicht digital signiert, steht auch in setupapi-dev.log.

Der hhdrvi.log gibt nichts her.

Bei direktem Verweis auf die oem.inf wird der Treiber kurz genommen,
dann plong plong mit Fehler aufgetreten, System kann die Datei nicht finden,
obwohl vorher gefunden.
Ev. Versuch mit Neustart und Erlauben des Gebrauchs nicht signierter Treiber via Easy BCD.

Re

Es ist traurig, dass Sie für Home keinen Telefonsupport anbieten.
Bei versiertem User wäre das Problem wahrscheinlich
bei schnellem Brainstorming in wenigen Minuten gelöst.

Auch Mails schreiben und Foren bedienen kostet Zeit ggf.
vom Homeoffice aus.
Telefonisch ist bei ausgewählten versierten Usern alles viel schneller gelöst.

Ich hatte vor Jahren schon mal dasselbe Problem.
Da löste es sich irgendwie durch diverse Neuinstallationen von selbst.

Viele User nehmen dann Freeware, wie Daemon Tools,
oder Virtual Clone Drive.

Die VCD Diagnose bringt keinerlei Fehlermeldung !

Re

Intern braucht man das nicht lassen, warum auch ??
Es sollen doch auch die anderen was lernen oder Lösungen lesen !

Gruß an Herrn Mäcker, falls es den noch gibt.
Hatte auch schon mal mit dem telefoniert früher.

In meinem Beruf werden Probleme in Sekunden per Telefon gelöst.

MfG, Dr.med. M.S.

Re

Version=1
EventType=PnPDriverImportError
EventTime=132277494045295863
Consent=1
ReportIdentifier=52032056-5da1-11ea-85c9-00262dca3bea
Response.type=4
Sig[0].Name=Architektur
Sig[0].Value=x64
Sig[1].Name=Win32-Fehler
Sig[1].Value=00000002
Sig[2].Name=INF-Name
Sig[2].Value=oem50.inf
Sig[3].Name=Treiberpakethash
Sig[3].Value=3e1ef15ba333dd48a59884f880f480878b96089f
DynamicSig[1].Name=Betriebsystemversion
DynamicSig[1].Value=6.1.7601.2.1.0.256.4
DynamicSig[2].Name=Gebietsschema-ID
DynamicSig[2].Value=1031
FriendlyEventName=Die Treibersoftware konnte nicht installiert werden.
ConsentKey=PnPDriverImportError
AppName=Gerätetreiberinstallation
AppPath=C:\Windows\System32\mmc.exe
ReportDescription=Es wurden nicht alle erforderlichen Dateien für die Installation dieser Gerätetreibersoftware kopiert. Möglicherweise ist die Treibersoftware nicht für diese Windows-Version ausgelegt.

Es geht also auch nicht beim Erlauben von Gebrauch unsignierter Treiber !

Was für eine Mühsal und Zeitverschwendung beider Seiten für ein kleines Problem !

PAE

Zunächst einmal vielen Dank für die Informationen. Ja, der Herr Mäcker, das bin ich. Bitte entschuldigen Sie, dass ich mich leider nicht an Sie erinnern kann... ;-)
Intern belassen wir immer die Diagnose, da diese auch die Seriennummer und andere persönliche Informationen enthält.
Sie haben natürlich Recht: Probleme lassen sich manchmal durch ein Telefonat schneller lösen, insbesondere dann, wenn man einen einigermaßen versierten Kunden am Apparat hat. Die Erfahrung hat uns jedoch gezeigt, dass dies häufig nicht der Fall ist. Wie sollen wir im Vorfeld wissen, ob der Kunde technisch versiert ist oder nicht? Erfahrungsgemäß ist Telefonsupport im Durchschnitt betrachtet kostenintensiver, bei einem niedrigpreisigen Produkt wie Virtual CD müssen wir da schon kalkulieren. Bei den höherpreisigen Produkten wie Virtual CD NMS oder TS leisten wir auch Telefonsupport.

Nun noch einmal zu Ihrem Fall: "Could not set scsi security, Error Code 2." hat was zum Klingeln gebracht, s. KB-Artikel. Dieser bezieht sich jedoch auf Virtual CD v8. In der Reg-Datei zum Download müsste es daher auch statt vdrv8000.ini vdrv1000.ini heißen. Einen Versuch wäre es wert...

Ansonsten gibt es Einträge im Eventlog, die nähere Hinweise geben könnten?

Viele Grüße

Unter Windows mit aktiviertem PAE können keine virtuellen Laufwerke angelegt werden.

Re

In der Reg. steht vdrv1000 und vdrv1000.ini !
Der Reg_DWORD Eintrag lautet jedoch

von VCDFlags 0x200000033554432 !

Es ist die Frage ob das das Problem wirklich ist !

Es bleibt immer noch der PnP Driverimporterror !

Für mich ist die Frage, ob die die oem50.inf ev. korrupt oder defekt ist !

Diagnose

OK, auf Nachfrage beim zuständigen Entwickler hat der so etwas auch noch nicht gesehen, ein Problem mit PAE sollte es jedoch nicht sein.

Was wir zwingend für den weiteren Support benötigen ist der vollständige Inhalt der Virtual CD-Diagnose mit Installationsprotokoll (s.o.) sowie Meldungen aus der Ereignisanzeige, wenn denn solche vorhanden sind.

Vielen Dank und viele Grüße

Re

Die Diagnose ergab nichts. Das Einzige wie gesagt, dass die oem.inf genommen wird und dann die Meldung kommt:
Nicht gefunden, was ja widersinnig ist !
Die EAZ Meldungen hat ich geschrieben.
Ich checke das Ganze noch mal selbst.
Viren, andere Defekte etc pp
Bisher habe ich immer eine Lösung gefunden, meist selbst, es dauert nur.

Diagnose

Es wäre schon schön, wenn Sie es uns überlassen hätten, zu beurteilen, ob die Diagnose etwas ergibt. Dies können Sie bei allem Respekt wahrscheinlich nicht selbst beurteilen...

Sollten Sie also nicht weiterkommen, posten Sie bitte die komplette Diagnose wie beschrieben.

Vielen Dank und freundliche Grüße

Re

Nur soviel:
Das mit Win 7 Enterprise upgegradete und aufgefrischte System vorher Ultimate hat ev. ein Problem mit Netframework, was ich gerade zu beheben suche.
Auch werden einige Win Updates nicht installiert.
Ob es da einen Zusammenhang gibt, unklar.
Nach dem nochmaligen Inplace Upgrade mit einer aktuellen EP Version ging alles, bis auf einen Defekt im Netframework
und da ging dann auch die Installation von VCD durch.

Re

Es könnte auch daran liegen, dass 7 EP automatisch ein Firmennetzwerk hat.
Und die Version die ich habe eben nur für Privatuser ist,
der ich auch bin.
Keine Ahnung. Ev. kann ich das Netzwerk ausschalten und auf Heim setzen.

Treiberinstallation

Dass die Installation auf einem frisch aufgesetzten Rechner funktioniert, überrascht jetzt nicht... ;-) In der Tat ist dies manchmal auch die einzige Lösung, wenn man nicht herausfinden kann, wer oder was die Treiberinstallation verhindert. Im vorliegenden Fall liefert die Diagnose aber durchaus gleich zwei Verdächtige:
C:\Windows\system32\drivers\iaStorF.sys - Intel Rapid Storage Technology Filter driver - x64 - Intel Corporation - 12.9.0.1001
C:\Windows\system32\DRIVERS\oodivd.sys - O&O DiskImage Virtual Devices Driver (x64) - O&O Software GmbH - 9.0.0.193

Zum Entfernen von Filtertreibern lesen Sie bitte einmal folgenden KB-Artikel:

Entfernen von Filtertreibern aus der Registry

Re

An den beiden Treibern liegt es mit Sicherheit nicht.
Die waren immer da.
Es liegt offensichtlich alleine am Umwandeln von 7 U auf 7 EP per IU,
ein Szenario, das von MS nicht vorgesehen ist.
Dabei treten Probleme mit Netframework auf, dass sich weder deinstallieren noch reparieren noch ändern lässt.
In der Folge auch Probleme mit Updates, angestoßen und nicht zu Ende geführt, rekursiv.
Damit hängt ev. auch das Treiberproblem von VCD zusammen,
so dass keine virtuellen LW erzeugt werden.
Die Diagnose liefert da nichts.
Es sind eher versteckte interne Probleme mit NFW u.a.
System wurde wieder auf U gesetzt per Backup.

Filtertreiber

Einen Versuch wäre es wert gewesen. Aber offensichtlich haben Sie Ihr Problem ja gelöst, so dass wir den Thread schließen können.

Mit "Netframework" meinen Sie das .NET Framework? Daran kan es nicht liegen, da Virtual CD dieses nicht nutzt. Vermutlich werden wir die eigentliche Ursache für das Problem im vorliegenden Fall nicht ermitteln können...

Re

Wie sich das NFW schreibt ist doch völlig egal !
Es hing mit U auf EP zusammen.
Auch wenn das NFW nicht genutzt wird, gibt es wahrscheinlich Seiteneffekte,
was auch das Updateproblem zeigte.
Und die Diag von VCD war beim Defekt exakt dieselbe
wie beim funktionierenden System !
MfG !

Antwort schreiben

* = erforderliche Daten