The Phantom Drive support forum


Double click VC desktop icon doesn't work sometimes

I have VC version I use it frequently. In the last month I have installed a new app (ancestry.exe) for genealogy searches. Most times after running this app I am unable to initiate the VC app. When I double-click the desktop icon I see a brief display of the circular windmill - then nothing. The only way I have found of restoring the correct functioning of the app is to run a windows repair program (actually RESTORO) which tries to repair the Windows system and includes a registry repair facility. This process takes about half an hour. Can you identify what the problem might be and possibly suggest an easier way to fix it please?


Can you start the Virtual CD Center via the Quick Start Icon in the system tray either by double-clicking the tray icon or right-clicking and choosing the CD Center?

Where can I download the Ancestry software for testing?

Response to request for more information

Thank you for your response to my query. The reason I have taken so long to reply is that since posting my query for help the VCD application icon has steadfastly worked correctly every time, so I have been unable to provide any additional information to help you diagnose the fault (if any). I don't understand it. It consistently failed the way I described up to the point of requesting your help. In the circumstances, there doesn't seem any point in continuing with this task so I am happy to let the matter drop, at least for the time being. Thank you for your interest nevertheless. Alan

Problem doesn't occur anymore

Dear Alan,

thanks for your feedback. Just let us know when the problem occurs again.

Kind regards,

Problem reappeared

Since my last message reporting that the problem had gone away, after a few days it has reappeared. I tried initiating the Virtual CD Centre via the Quick Start Icon as you suggested with the same symptoms as before. A brief (less than a second) period of activity, then nothing. If you wish to try to reproduce the problem, the software I am using is available from They offer a 14-day free trial that you may be able to take advantage of. Thank you for your support. Alan


Dear Alan,

please understand that we don't like to install a software where we have to register and then after 2 weeks we have to un-register again to avoid to pay for a service we don't want...
You can provide us the software for download I you want.

Furthermore I don't think that ancestry is the real or only culprit in this case. What makes me wonder is that Virtual CD works for a while and then out of a sudden does not start anymore. Are you able to determine which action makes Virtual CD stop working , e.g. starting Ancestry (or is Ancestry auto-starting on login?).

Kind regards,

New answer

* = required information